aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gpm/install-shared-libs-with-+x-perms.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/gpm/install-shared-libs-with-+x-perms.patch')
-rw-r--r--testing/gpm/install-shared-libs-with-+x-perms.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/gpm/install-shared-libs-with-+x-perms.patch b/testing/gpm/install-shared-libs-with-+x-perms.patch
new file mode 100644
index 0000000000..d32619c2da
--- /dev/null
+++ b/testing/gpm/install-shared-libs-with-+x-perms.patch
@@ -0,0 +1,25 @@
+From 01373f6fd5dd274116c8ec693245677dbf5390e6 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 28 Oct 2012 07:25:40 -0400
+Subject: [PATCH] install shared lib with +x perms
+
+This is executable code, so it should have +x perms on the file.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ src/Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index d3b1dcd..6b60ad3 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -113,7 +113,7 @@ install: check
+ # 2.x goes along; unfortunately that means an additional
+ # headache in cases like this
+ if test "x@SHLIB@" != "x" ; then \
+- $(INSTALL_DATA) -m 644 lib/libgpm.so.@abi_full@ $(libdir)/libgpm.so.@abi_full@ ; \
++ $(INSTALL_DATA) -m 755 lib/libgpm.so.@abi_full@ $(libdir)/libgpm.so.@abi_full@ ; \
+ cd $(libdir) && $(LN_S) -f libgpm.so.@abi_full@ libgpm.so.@abi_lev@ ; \
+ echo "WARNING: We installed a lib, you should now call ldconfig" ; \
+ echo "f.i.: ldconfig -n -l $(libdir)/libgpm.so.@abi_full@" ; \