aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hfst/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hfst/APKBUILD')
-rw-r--r--testing/hfst/APKBUILD69
1 files changed, 69 insertions, 0 deletions
diff --git a/testing/hfst/APKBUILD b/testing/hfst/APKBUILD
new file mode 100644
index 0000000000..34b0f921a7
--- /dev/null
+++ b/testing/hfst/APKBUILD
@@ -0,0 +1,69 @@
+# Contributor: Frankie Robertson <frankie@robertson.name>
+# Maintainer:
+pkgname=hfst
+pkgver=3.8.2
+pkgrel=0
+pkgdesc="Helsinki Finite-State Transducer Technology toolkit"
+url="http://www.ling.helsinki.fi/kieliteknologia/tutkimus/hfst/"
+arch="all"
+license="LGPL3"
+depends=""
+depends_dev=""
+makedepends="$depends_dev python3 python3-dev python python-dev swig"
+install=""
+subpackages="hfst-dev hfst-doc hfst-python3 hfst-python"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz missing_unistd_include.patch unnulled_getline_usage.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --enable-proc \
+ --without-foma \
+ --enable-lexc \
+ -enable-all-tools \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ cd swig
+ /usr/bin/env python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ /usr/bin/env python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+python() {
+ depends="python"
+ mkdir -p "$subpkgdir"/usr/lib/
+ cp -r "$pkgdir"/usr/lib/python2* "$subpkgdir"/usr/lib/
+}
+
+python3() {
+ depends="python3"
+ mkdir -p "$subpkgdir"/usr/lib/
+ cp -r "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
+}
+
+md5sums="814ffcf9624e24906335b1e12266e8fb hfst-3.8.2.tar.gz
+4aef69581668aa22cf1e93cbd6493030 missing_unistd_include.patch
+a87269069eeed9e2d564a3c6a4fcf030 unnulled_getline_usage.patch"
+sha256sums="bdae235271368a8d13db4a224fe8a53cf7266b8fce194cf63c96031e007e3d63 hfst-3.8.2.tar.gz
+158d633416a482308f420c6d9e3c8648f96238fc7209d70055e629a0ff978b80 missing_unistd_include.patch
+bafa91e28828b571f72d5e7709cb8e0e8400fa8b8dfead86a7f3a6cab26fb408 unnulled_getline_usage.patch"
+sha512sums="415fafd38259f1c4580aa833c23d8315c605e44752380243c514783f657bae996b8a4af424faf830f6d8f5df90a4d849d8487858ce691dae8993dc8656132c9a hfst-3.8.2.tar.gz
+0bfc63709dbefaaa4084bf78d169283a58ab4ee586e800446f5d92ee179d4c84959802f54e72ffa5366c49a2a30883deb54c562c9dcace21662d5cbdd06789d6 missing_unistd_include.patch
+0baed95620943341c2de9565921b423f75fd7b0b2c247dd2d3ce4021e10e257fa57bff5164b145c9138e654c1e446a98bf6caf585bcfa9a2e870b96885ca8548 unnulled_getline_usage.patch"