aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hidapi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hidapi/APKBUILD')
-rw-r--r--testing/hidapi/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/hidapi/APKBUILD b/testing/hidapi/APKBUILD
index 6397d367b7..370985f7bb 100644
--- a/testing/hidapi/APKBUILD
+++ b/testing/hidapi/APKBUILD
@@ -14,7 +14,8 @@ options="!check"
makedepends="libusb-dev libtool eudev-dev linux-headers autoconf automake"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/signal11/$pkgname/archive/$pkgname-${_relver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/signal11/$pkgname/archive/$pkgname-${_relver}.tar.gz
+ libusb_include_path.patch"
builddir="$srcdir/$pkgname-$pkgname-$_relver"
prepare() {
@@ -25,7 +26,9 @@ prepare() {
build() {
cd "$builddir"
- ./configure \
+ # Linker flags generated by automake are broken. It is easier to work
+ # around by setting LDFLAGS env than messing with automake.
+ LDFLAGS="$LDFLAGS -lusb-1.0 -ludev" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -44,4 +47,5 @@ package() {
"$pkgdir"/usr/share/licenses/$pkgname
}
-sha512sums="4529d74e715c47d788b533d94bf0ef35fa773240c9a59558d30c5ecc78cf46961de368f9385f5d84d378eaf8d4e941d553341e839674e562ccfcf52726620a65 hidapi-0.8.0_rc1.tar.gz"
+sha512sums="4529d74e715c47d788b533d94bf0ef35fa773240c9a59558d30c5ecc78cf46961de368f9385f5d84d378eaf8d4e941d553341e839674e562ccfcf52726620a65 hidapi-0.8.0_rc1.tar.gz
+94eabf809049d82585599787768bcfab795e400593f130c98c4fdf0db53629f251e5aaa39a7a469b6ff3d240f5b1edb1b2f099bf6034a6dcfa182dc2dae851a0 libusb_include_path.patch"