aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hitch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hitch/APKBUILD')
-rw-r--r--testing/hitch/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/testing/hitch/APKBUILD b/testing/hitch/APKBUILD
index a4f6e473ba..885640ecdf 100644
--- a/testing/hitch/APKBUILD
+++ b/testing/hitch/APKBUILD
@@ -1,21 +1,26 @@
# Contributor: Raphael Cohn <raphael.cohn@stormmq.com>
# Maintainer: Raphael Cohn <raphael.cohn@stormmq.com>
pkgname=hitch
-pkgver=1.4.6
-pkgrel=2
+pkgver=1.4.8
+pkgrel=0
pkgdesc="hitch is a TLS / SSL endpoint like stunnel"
url="https://hitch-tls.org/"
arch="all"
license="BSD"
-depends="libev"
-makedepends="libev-dev libressl-dev automake autoconf py-docutils bison flex"
+makedepends="libev-dev openssl-dev automake autoconf py-docutils bison flex
+ autoconf automake libtool"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/varnish/$pkgname/archive/$pkgname-$pkgver.tar.gz"
+source="https://hitch-tls.org/source/hitch-$pkgver.tar.gz
+ disable-Werror.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ autoreconf -vif -I.
+}
-builddir="$srcdir"/$pkgname-$pkgname-$pkgver
build() {
cd "$builddir"
- ./bootstrap
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,4 +35,5 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="98caf993aee7b562a39560fc9c634497636e19b295c8a71306b1e1964d5dea5efc14f0b7faa50bff3448b8977ce15521fbce9dc5ceea9f02162c8ebd18ed4eda hitch-1.4.6.tar.gz"
+sha512sums="4225391822c6e223e795bbc4756d55dcd8d16f61b42cf1e336205ae0707c1ba1f86b4c0be1457695d0f0ad4ec1906fdacb46cdd0dbbe50d00385380a9cbad617 hitch-1.4.8.tar.gz
+0c0eca5142dc9023f2615e7b8bc3835ac1bf531d687de05024ca485b54244ee5c58e643b0dd933f1c23ba33f519d98fba8a4ebaec911879af08ce33d9ba6cd7a disable-Werror.patch"