aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hitch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hitch/APKBUILD')
-rw-r--r--testing/hitch/APKBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/testing/hitch/APKBUILD b/testing/hitch/APKBUILD
index 1315a3afd4..0708f9450f 100644
--- a/testing/hitch/APKBUILD
+++ b/testing/hitch/APKBUILD
@@ -1,22 +1,15 @@
# Contributor: Raphael Cohn <raphael.cohn@stormmq.com>
# Maintainer: Raphael Cohn <raphael.cohn@stormmq.com>
pkgname=hitch
-pkgver=1.5.0
-pkgrel=1
+pkgver=1.5.1
+pkgrel=0
pkgdesc="hitch is a TLS / SSL endpoint like stunnel"
url="https://hitch-tls.org/"
arch="all"
license="BSD-2-Clause"
-makedepends="libev-dev openssl-dev automake autoconf py3-docutils bison flex
- libtool"
+makedepends="libev-dev openssl-dev py3-docutils bison flex"
subpackages="$pkgname-doc"
-source="https://hitch-tls.org/source/hitch-$pkgver.tar.gz
- disable-Werror.patch"
-
-prepare() {
- default_prepare
- autoreconf -vif -I.
-}
+source="https://hitch-tls.org/source/hitch-$pkgver.tar.gz"
build() {
./configure \
@@ -26,12 +19,11 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --with-rst2man=/usr/bin/rst2man-3
+ --enable-tcp-fastopen
make
}
package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="17991d9a82635456fcd0cebf0f1b067183bc0a02eaf0d1437ba3369674a2a9880ca8774afde984710123c46b472bdbe3b1bf6770e7475d5d24170a7674a48be5 hitch-1.5.0.tar.gz
-0c0eca5142dc9023f2615e7b8bc3835ac1bf531d687de05024ca485b54244ee5c58e643b0dd933f1c23ba33f519d98fba8a4ebaec911879af08ce33d9ba6cd7a disable-Werror.patch"
+sha512sums="61fca7c55cc01ae314a216109249877a9b9bb9544ada5704bdec608f68ef3dc03d30de9fc1796ed519cad074e72c4104213714c2a30873378133d7b1f14cbf17 hitch-1.5.1.tar.gz"