aboutsummaryrefslogtreecommitdiffstats
path: root/testing/httpry
diff options
context:
space:
mode:
Diffstat (limited to 'testing/httpry')
-rw-r--r--testing/httpry/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/httpry/APKBUILD b/testing/httpry/APKBUILD
new file mode 100644
index 0000000000..9a3c419338
--- /dev/null
+++ b/testing/httpry/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=httpry
+pkgver=0.1.6
+pkgrel=0
+pkgdesc="A packet sniffer designed for HTTP traffic"
+url="http://dumpsterventures.com/jason/httpry/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://dumpsterventures.com/jason/httpry/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -m755 -D "$_builddir"/$pkgname "$pkgdir"/usr/sbin/$pkgname
+ install -m644 -D "$_builddir"/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
+
+md5sums="ef016e3e0e950993b7c9811b6859ec4d httpry-0.1.6.tar.gz"