aboutsummaryrefslogtreecommitdiffstats
path: root/testing/iasl
diff options
context:
space:
mode:
Diffstat (limited to 'testing/iasl')
-rw-r--r--testing/iasl/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/iasl/APKBUILD b/testing/iasl/APKBUILD
index 65a098544b..dfd455dc07 100644
--- a/testing/iasl/APKBUILD
+++ b/testing/iasl/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Roger Pau Monne <roger.pau@entel.upc.edu>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iasl
pkgver=20111123
pkgrel=0
@@ -12,14 +12,19 @@ depends_dev="flex bison"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc"
+# license was found here:
+# http://acpica.org/downloads/unix_source_code.php
source="http://www.acpica.org/download/acpica-unix-$pkgver.tar.gz
COPYING"
_builddir="$srcdir"/acpica-unix-$pkgver
build() {
- cd "$_builddir"
- make -j1 -C compiler || return 1
+ cd "$_builddir"/compiler
+ # parallel build fix
+ make aslcompilerlex.c aslcompilerparse.c dtparserlex.c dtparserparse.c\
+ || return 1
+ make || return 1
}
package() {