aboutsummaryrefslogtreecommitdiffstats
path: root/testing/inotify-tools
diff options
context:
space:
mode:
Diffstat (limited to 'testing/inotify-tools')
-rw-r--r--testing/inotify-tools/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/inotify-tools/APKBUILD b/testing/inotify-tools/APKBUILD
new file mode 100644
index 0000000000..1aeee58125
--- /dev/null
+++ b/testing/inotify-tools/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor:
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname="inotify-tools"
+pkgver=3.14
+pkgrel=0
+pkgdesc="C library and CLI tools providing a simple interface to inotify"
+url="http://github.com/rvoicilas/inotify-tools"
+arch="x86 x86_64"
+license="GPL"
+depends=
+makedepends="wget"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/downloads/rvoicilas/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+ return 0
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="b43d95a0fa8c45f8bab3aec9672cf30c inotify-tools-3.14.tar.gz"