aboutsummaryrefslogtreecommitdiffstats
path: root/testing/iotop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/iotop/APKBUILD')
-rw-r--r--testing/iotop/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/iotop/APKBUILD b/testing/iotop/APKBUILD
new file mode 100644
index 0000000000..8abe65cf9f
--- /dev/null
+++ b/testing/iotop/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=iotop
+pkgver=0.4.4
+pkgrel=0
+pkgdesc="I/O monitoring tool"
+url="http://guichaz.free.fr/iotop/"
+arch="noarch"
+license="GPL"
+depends="python"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://guichaz.free.fr/iotop/files/iotop-$pkgver.tar.gz"
+
+_builddir="$srcdir"/iotop-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="03f9a5866435cd67108cdb4f68b0d1f3 iotop-0.4.4.tar.gz"