aboutsummaryrefslogtreecommitdiffstats
path: root/testing/julia/0002-verbose-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/julia/0002-verbose-build.patch')
-rw-r--r--testing/julia/0002-verbose-build.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/testing/julia/0002-verbose-build.patch b/testing/julia/0002-verbose-build.patch
index 49bb036996..c13f93fead 100644
--- a/testing/julia/0002-verbose-build.patch
+++ b/testing/julia/0002-verbose-build.patch
@@ -1,17 +1,17 @@
Description: Ensure that build is verbose
Author: Sébastien Villemot <sebastien@debian.org>
+Author: Shiz <hi@shiz.me>
Forwarded: not-needed
-Last-Update: 2013-10-09
+Last-Update: 2017-05-19
---
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- a/deps/Makefile
-+++ b/deps/Makefile
-@@ -756,7 +756,7 @@
- touch -c $(LIBUV_SRC_DIR)/Makefile.in
- touch -c $(LIBUV_SRC_DIR)/configure
- cd $(LIBUV_SRC_DIR) && \
-- ./configure --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS)
-+ ./configure --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS) --disable-silent-rules
+--- a/deps/libuv.mk
++++ b/deps/libuv.mk
+@@ -33,7 +33,7 @@
+ touch -c $(SRCDIR)/srccache/$(LIBUV_SRC_DIR)/configure
+ mkdir -p $(dir $@)
+ cd $(dir $@) && \
+- $< --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS)
++ $< --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS) --disable-silent-rules
touch -c $@
- $(UV_SRC_TARGET): $(LIBUV_SRC_DIR)/config.status
- $(MAKE) -C $(LIBUV_SRC_DIR) $(UV_MFLAGS)
+ $(UV_SRC_TARGET): $(BUILDDIR)/$(LIBUV_SRC_DIR)/config.status
+ $(MAKE) -C $(dir $<) $(UV_MFLAGS)