aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kcoreaddons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kcoreaddons/APKBUILD')
-rw-r--r--testing/kcoreaddons/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/kcoreaddons/APKBUILD b/testing/kcoreaddons/APKBUILD
index 6eea3699f3..3afc2933ca 100644
--- a/testing/kcoreaddons/APKBUILD
+++ b/testing/kcoreaddons/APKBUILD
@@ -22,8 +22,13 @@ build() {
}
check() {
+ local disabled_tests="kdirwatch_qfswatch"
+ case "$CARCH" in
+ s390x) disabled_tests="$disabled_tests|kdirwatch_inotify";;
+ esac
+
# Excluded test requires >8000 open files
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(kdirwatch_qfswatch_unittest)'
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "($disabled_tests)_unittest"
}
package() {