aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kmod/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kmod/APKBUILD')
-rw-r--r--testing/kmod/APKBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/testing/kmod/APKBUILD b/testing/kmod/APKBUILD
deleted file mode 100644
index c34e339c30..0000000000
--- a/testing/kmod/APKBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=kmod
-pkgver=4
-pkgrel=0
-pkgdesc="Linux kernel module management utilities"
-url="http://git.profusion.mobi/cgit.cgi/kmod.git/"
-arch="all"
-license="GPLv2+"
-depends=""
-depends_dev=""
-makedepends="$depends_dev zlib-dev xz-dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://packages.profusion.mobi/kmod/kmod-$pkgver.tar.xz"
-
-_builddir="$srcdir"/kmod-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --bindir=/bin \
- --with-rootprefix= \
- --with-rootlibdir=/lib \
- --with-zlib \
- --with-xz \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
-}
-
-libs() {
- pkgdesc="Libraries to handle kernel module loading and unloading"
- mkdir -p "$subpkgdir"/
- mv "$pkgdir"/lib "$subpkgdir"/
-}
-
-md5sums="e14450a066a48accd0af1995b3c0232d kmod-4.tar.xz"