aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ksmtp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ksmtp/APKBUILD')
-rw-r--r--testing/ksmtp/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/ksmtp/APKBUILD b/testing/ksmtp/APKBUILD
new file mode 100644
index 0000000000..2e2162961f
--- /dev/null
+++ b/testing/ksmtp/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=ksmtp
+pkgver=19.04.2
+pkgrel=0
+pkgdesc="Job-based library to send email through an SMTP server"
+arch="all"
+url="https://kontact.kde.org"
+license="LGPL-2.1-or-later"
+depends_dev="qt5-qtbase-dev kcoreaddons-dev ki18n-dev kio-dev cyrus-sasl-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+options="!check" # Broken
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="3cfa70f66f4e044f3932272d1ae6a1c8b49110c1d669ecf9ee3ba75c97a02083356f6381fc82b0a9bd6936176171378c0bba142d511207fdb62bcf3421fef8f0 ksmtp-19.04.2.tar.xz"