aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lab/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lab/APKBUILD')
-rw-r--r--testing/lab/APKBUILD35
1 files changed, 32 insertions, 3 deletions
diff --git a/testing/lab/APKBUILD b/testing/lab/APKBUILD
index 0b717ae6cb..1054870928 100644
--- a/testing/lab/APKBUILD
+++ b/testing/lab/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=lab
pkgver=0.16.0
-pkgrel=0
+pkgrel=1
pkgdesc="A Git Wrapper for GitLab"
url="https://zaquestion.github.io/lab/"
arch="all"
@@ -10,7 +10,14 @@ license="CC0-1.0"
depends="git"
makedepends="go"
checkdepends="bash"
-source="lab-$pkgver.tar.gz::https://github.com/zaquestion/lab/archive/v$pkgver.tar.gz"
+subpackages="
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch
+ "
+source="lab-$pkgver.tar.gz::https://github.com/zaquestion/lab/archive/v$pkgver.tar.gz
+ allow-completion.patch
+ xdg.patch
+ "
builddir="$srcdir/src/github.com/zaquestion/$pkgname"
options="net !check" # Tests require configured GitLab account with SSH keys
@@ -25,6 +32,8 @@ prepare() {
build() {
GO111MODULE=on go build -ldflags "-X main.version=$pkgver" -o bin/$pkgname
+ ./bin/lab completion bash > lab.bash
+ ./bin/lab completion zsh > _lab.zsh
}
package() {
@@ -37,4 +46,24 @@ cleanup_srcdir() {
default_cleanup_srcdir
}
-sha512sums="8036dd3921f2e02433274a4e3dc215e8afc604c385753105c8640f2795f4566641a30a27ce8ddb99496bab5101e573a7607ca3990c4e6587834a6ecf061e92f2 lab-0.16.0.tar.gz"
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ install -Dm644 "$builddir"/lab.bash \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ install -Dm644 "$builddir"/_lab.zsh \
+ "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
+}
+
+sha512sums="8036dd3921f2e02433274a4e3dc215e8afc604c385753105c8640f2795f4566641a30a27ce8ddb99496bab5101e573a7607ca3990c4e6587834a6ecf061e92f2 lab-0.16.0.tar.gz
+9241ae986e7669f46c6bafbf0532bff730eb11b74c73b37785d926c8dc88e9de528a6ad9d685e79e1e8a5e44b903dbe213af92648038fb59514ea2c696ea7dd4 allow-completion.patch
+f45e5f0ccfcfea03090b78fd2af200165883f329684e2301644b88828c072fedf8ff2832254ca3d44c0e1e95e60bff5145f5decbb85907ac9241cbaf5514a146 xdg.patch"