aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lab
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lab')
-rw-r--r--testing/lab/APKBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/testing/lab/APKBUILD b/testing/lab/APKBUILD
index c4bc4cf33b..0b717ae6cb 100644
--- a/testing/lab/APKBUILD
+++ b/testing/lab/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer:
-pkgname="lab"
-pkgver="0.16.0"
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=lab
+pkgver=0.16.0
pkgrel=0
pkgdesc="A Git Wrapper for GitLab"
url="https://zaquestion.github.io/lab/"
@@ -12,7 +12,7 @@ makedepends="go"
checkdepends="bash"
source="lab-$pkgver.tar.gz::https://github.com/zaquestion/lab/archive/v$pkgver.tar.gz"
builddir="$srcdir/src/github.com/zaquestion/$pkgname"
-options="net !check"
+options="net !check" # Tests require configured GitLab account with SSH keys
export GOPATH="$srcdir"
export CGO_ENABLED=0
@@ -32,12 +32,6 @@ package() {
"$pkgdir"/usr/bin/$pkgname
}
-check() {
- # this is disabled cause it tries to clone from
- # gitlab.com ssh repo without having a host key
- make test
-}
-
cleanup_srcdir() {
go clean -modcache
default_cleanup_srcdir