aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ldc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ldc/APKBUILD')
-rw-r--r--testing/ldc/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/ldc/APKBUILD b/testing/ldc/APKBUILD
index 568d5569a4..ea4e700519 100644
--- a/testing/ldc/APKBUILD
+++ b/testing/ldc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Mathias LANG <pro.mathias.lang@gmail.com>
pkgname=ldc
pkgver=1.20.0
-pkgrel=0
+pkgrel=1
pkgdesc="The LLVM-based D Compiler"
url="https://github.com/ldc-developers/ldc"
# LDC does not support host compiling on most of the architecture Alpine supports
@@ -40,7 +40,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DD_COMPILER="$builddir/stage1/bin/ldmd2" \