aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libell/APKBUILD')
-rw-r--r--testing/libell/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/libell/APKBUILD b/testing/libell/APKBUILD
new file mode 100644
index 0000000000..73843f95bb
--- /dev/null
+++ b/testing/libell/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Pedro Filipe <xpecex@outlook.com>
+pkgname=libell
+pkgver=0.9
+pkgrel=0
+pkgdesc="The Embedded Linux* Library (ELL) provides core, low-level functionality for system daemons."
+url="https://01.org/ell"
+arch="all"
+license="GPL-2.1"
+makedepends="libnl3-dev dbus linux-headers"
+subpackages="$pkgname-dev"
+source="https://mirrors.edge.kernel.org/pub/linux/libs/ell/ell-$pkgver.tar.xz
+ fix-WAIT_ANY-test-dbus.patch
+ "
+builddir="$srcdir/ell-$pkgver"
+options="!check" # testsuite shows unknown error in unit/test-cipher
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e1208066012b9ff927baae271f94116376ccd2577d7f6510cc1444eee912988aa1c25e8e8c9195cccfa39ed48fc8c2f07bd7a414719e6ce76ee1e5bd2a64b8c3 ell-0.9.tar.xz
+456f49b0f9c5ff93b1af2221d59f224b7b61847360e3f25b0d42af733fc4b296d30bb50349e00437c6e235c0bacba74c1a5b502dcc1b0c4bdbc38f101b3d4220 fix-WAIT_ANY-test-dbus.patch"