aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libfakekey/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libfakekey/APKBUILD')
-rw-r--r--testing/libfakekey/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/libfakekey/APKBUILD b/testing/libfakekey/APKBUILD
new file mode 100644
index 0000000000..dd229bee23
--- /dev/null
+++ b/testing/libfakekey/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Daniele Debernardi <drebrez@gmail.com>
+# Maintainer: Daniele Debernardi <drebrez@gmail.com>
+pkgname=libfakekey
+pkgver=0.3
+pkgrel=0
+pkgdesc="X virtual keyboard library"
+url="https://www.yoctoproject.org/software-item/matchbox/"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="autoconf automake libtool libxtst-dev"
+subpackages="$pkgname-dev"
+source="http://git.yoctoproject.org/cgit/cgit.cgi/$pkgname/snapshot/$pkgname-$pkgver.tar.gz"
+options="!check" # No test suite present
+
+prepare() {
+ default_prepare
+ autoreconf --install
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static
+ make AM_LDFLAGS=-lX11
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9c09007c6ab616095bdf69669cfdf0d176d44beaeb6b2a0fe8e310bb835d3f241ca7499dcb523c1eeeb24968ef908c1951f97352da419fc1bbb3883cb43dd963 libfakekey-0.3.tar.gz"