aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libhtp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libhtp/APKBUILD')
-rw-r--r--testing/libhtp/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/libhtp/APKBUILD b/testing/libhtp/APKBUILD
new file mode 100644
index 0000000000..3274f8173a
--- /dev/null
+++ b/testing/libhtp/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Steve McMaster <code@mcmaster.io>
+# Maintainer: Steve McMaster <code@mcmaster.io>
+pkgname=libhtp
+pkgver=0.5.23
+pkgrel=0
+pkgdesc="HTTP normalizer and parser library"
+url="https://github.com/OISF/libhtp"
+arch="all"
+license="BSD"
+depends="zlib"
+depends_dev="zlib-dev"
+makedepends="automake autoconf libtool zlib-dev"
+install=""
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/OISF/libhtp/archive/$pkgver.tar.gz
+"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ autoreconf -vif || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="5a0a9e2f8ee47b5f9293ea28cda28540 libhtp-0.5.23.tar.gz"
+sha256sums="b511ee90a92f7c7d984f8a3ad973244095b7377b866db8a32d652c9c59f57d93 libhtp-0.5.23.tar.gz"
+sha512sums="df1772fead1f108cb8941f461e9b293c75cd64da698c192c049c6f494aa8640e3fa7c54dbb9c5a61940190ab98afe1cbf3da3cca121bb90991bcdaff7c0bbedf libhtp-0.5.23.tar.gz"