aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libimagequant
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libimagequant')
-rw-r--r--testing/libimagequant/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/libimagequant/APKBUILD b/testing/libimagequant/APKBUILD
new file mode 100644
index 0000000000..5b29aa7e8a
--- /dev/null
+++ b/testing/libimagequant/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=libimagequant
+pkgver=2.12.1
+pkgrel=0
+pkgdesc="Small, portable C library for high-quality conversion of RGBA images to 8-bit indexed-color (palette) images."
+url="https://pngquant.org/lib/"
+arch="all"
+license="GPL-3.0-or-later"
+options="!check" # No test suite
+makedepends="bash"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ImageOptim/libimagequant/archive/$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="2e65d1ccae4e885e200446756496c2446696f0d4c7057d85e40c9ab4d524fed5505584f21f240ce3a7c589b9156ccb117cf5b1562b4851f3fbf14bf11fed0f13 libimagequant-2.12.1.tar.gz"