aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libmpack/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libmpack/APKBUILD')
-rw-r--r--testing/libmpack/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/testing/libmpack/APKBUILD b/testing/libmpack/APKBUILD
index d850a7d41c..1f62a9392a 100644
--- a/testing/libmpack/APKBUILD
+++ b/testing/libmpack/APKBUILD
@@ -18,8 +18,15 @@ build() {
}
check() {
+ local out
cd "$builddir"
- make test
+
+ # Tests prints thousands lines, so print only last few when fails.
+ out=$(make test) || {
+ echo "Tests failed, printing last 50 lines of the output..."
+ printf '%s\n' "$out" | tail -n 50
+ return 1
+ }
}
package() {