aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libndp
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libndp')
-rw-r--r--testing/libndp/APKBUILD55
-rw-r--r--testing/libndp/fix-fd_set.patch10
2 files changed, 0 insertions, 65 deletions
diff --git a/testing/libndp/APKBUILD b/testing/libndp/APKBUILD
deleted file mode 100644
index 556ffb47ad..0000000000
--- a/testing/libndp/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
-# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
-pkgname=libndp
-pkgver=1.4
-pkgrel=0
-pkgdesc="Library for IPv6 Neighbor Discovery Protocol"
-url="http://libndp.org"
-arch="all"
-license="GPL2.1"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://libndp.org/files/$pkgname-$pkgver.tar.gz
- fix-fd_set.patch
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --disable-static \
- --libexecdir=/usr/lib \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-md5sums="52c708d4b8729ae6e3781b3737a85e16 libndp-1.4.tar.gz
-7b1e885680e9677de2f25707850db7dd fix-fd_set.patch"
-sha256sums="3a0be247ec024bd72fe5b40ea9491519c4023c7faf078311196fab817b2fd55f libndp-1.4.tar.gz
-401a6d2601790f136e9c7b51b49003c3994df93136c6acdb289ce377d7068942 fix-fd_set.patch"
-sha512sums="a84d4d6672bf83bcf865eef8986e7bbcc49587686c5085a5ce5f346791223ede0e60db3b990055afc4f0005182aa1b5546c459306d2955f95d00ffb68bd58766 libndp-1.4.tar.gz
-291503b1a9b21ae3e75d0048fadaa0bace989c6091ddb7238ed7920d4daa968bbd66608432de341fa2cde33d440dcd1b679bc590c7b8d91a68363f5469abc92b fix-fd_set.patch"
diff --git a/testing/libndp/fix-fd_set.patch b/testing/libndp/fix-fd_set.patch
deleted file mode 100644
index 7797418c1a..0000000000
--- a/testing/libndp/fix-fd_set.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- libndp-1.4/utils/ndptool.c
-+++ libndp-1.4/utils/ndptool.c.new
-@@ -22,6 +22,7 @@
- #include <unistd.h>
- #include <string.h>
- #include <signal.h>
-+#include <sys/select.h>
- #include <sys/signalfd.h>
- #include <getopt.h>
- #include <net/if.h>