aboutsummaryrefslogtreecommitdiffstats
path: root/testing/liboauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/liboauth/APKBUILD')
-rw-r--r--testing/liboauth/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/liboauth/APKBUILD b/testing/liboauth/APKBUILD
new file mode 100644
index 0000000000..2e0c42518f
--- /dev/null
+++ b/testing/liboauth/APKBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=liboauth
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="OAuth library functions"
+url="http://liboauth.sourceforge.net/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev="nss-dev curl-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://liboauth.sourceforge.net/pool/liboauth-$pkgver.tar.gz"
+
+_builddir="$srcdir"/liboauth-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-nss \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="689b46c2b3ab1a39735ac33f714c4f7f liboauth-1.0.3.tar.gz"
+sha256sums="0df60157b052f0e774ade8a8bac59d6e8d4b464058cc55f9208d72e41156811f liboauth-1.0.3.tar.gz"
+sha512sums="5a13818dbb3e0df76f7a3fde451eff4f90c9bebfe2076a294921af0c07c2b0789f717f0f862ac6961562d4227e016dc198ddd7efb9c7ac599c3bfbcdb2ac33fa liboauth-1.0.3.tar.gz"