aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libphonenumber
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libphonenumber')
-rw-r--r--testing/libphonenumber/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/libphonenumber/APKBUILD b/testing/libphonenumber/APKBUILD
new file mode 100644
index 0000000000..ab66059825
--- /dev/null
+++ b/testing/libphonenumber/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bhushan Shah <bshah@kde.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libphonenumber
+pkgver=8.10.14
+pkgrel=0
+pkgdesc="Library for parsing, formatting, and validating international phone numbers."
+url="https://github.com/googlei18n/libphonenumber"
+arch="all"
+license="Apache-2.0"
+depends_dev="boost-dev protobuf-dev icu-dev"
+makedepends="$depends_dev cmake gtest-dev"
+checkdepends="gtest"
+subpackages="$pkgname-static $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/$pkgname/archive/v$pkgver.tar.gz"
+
+build() {
+ cd "$builddir/cpp"
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir/cpp"
+ ./libphonenumber_test
+}
+package() {
+ cd "$builddir/cpp"
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="79e828d92c2447f03df96ff40acf4f64202c39501a92fc0abf9c3794825150d805d9922e990726b0606feb35332d6b0c46c0f6fa64ed1131c269652e27c8df7a libphonenumber-8.10.14.tar.gz"