aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libtorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libtorrent/APKBUILD')
-rw-r--r--testing/libtorrent/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/libtorrent/APKBUILD b/testing/libtorrent/APKBUILD
new file mode 100644
index 0000000000..06865bc7e5
--- /dev/null
+++ b/testing/libtorrent/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=libtorrent
+pkgver=0.12.9
+pkgrel=1
+pkgdesc='BitTorrent library written in C++'
+url='http://libtorrent.rakshasa.no/'
+arch='all'
+license='GPL'
+makedepends='libsigc++-dev openssl-dev'
+subpackages="$pkgname-dev"
+options='libtool'
+source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-debug \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="b128bbd324f03eb42ef5060080f87548 libtorrent-0.12.9.tar.gz"