aboutsummaryrefslogtreecommitdiffstats
path: root/testing/liburiparser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/liburiparser/APKBUILD')
-rw-r--r--testing/liburiparser/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/liburiparser/APKBUILD b/testing/liburiparser/APKBUILD
new file mode 100644
index 0000000000..05da3c0324
--- /dev/null
+++ b/testing/liburiparser/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor:
+# Maintainer:
+pkgname=liburiparser
+pkgver=0.7.5
+pkgrel=0
+pkgdesc="A strictly RFC 3986 compliant URI parsing and handling library"
+url="http://uriparser.sourceforge.net/"
+arch="all"
+license="BSD"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/sourceforge/uriparser/uriparser-${pkgver}.tar.gz"
+
+_builddir="${srcdir}"/"uriparser-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --disable-test --disable-doc
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="459c2786758929b92bfbd0cee25b5aa0 uriparser-0.7.5.tar.gz"