aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libuser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libuser/APKBUILD')
-rw-r--r--testing/libuser/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/libuser/APKBUILD b/testing/libuser/APKBUILD
new file mode 100644
index 0000000000..cdacfe5b81
--- /dev/null
+++ b/testing/libuser/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=libuser
+pkgver=0.62
+pkgrel=0
+pkgdesc="A standardized interface for manipulating and administering user and group accounts"
+url="https://fedorahosted.org/libuser"
+arch="all"
+license="LGPL"
+depends="python2"
+makedepends="python2-dev glib-dev popt-dev libexecinfo-dev linux-pam-dev
+autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py2-$pkgname:_py"
+source="https://fedorahosted.org/releases/l/i/$pkgname/$pkgname-$pkgver.tar.xz
+0001-Check-for-issetugid.patch
+0002-remove-unused-execinfo.h.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --with-python \
+ --disable-gtk-doc-html \
+ --disable-rpath
+ sed -i 's/SUBDIRS = po docs/SUBDIRS = po/' Makefile
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+_py() {
+ cd "$builddir"
+ pkgdesc="Python2 bindings for $pkgname"
+ depends="$pkgname"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir""/usr/lib/python2.7" "$subpkgdir"/usr/lib
+}
+
+md5sums="63e5e5c551e99dc5302b40b80bd6d4f2 libuser-0.62.tar.xz
+867b1b35a9c029f935a4da70b3f41722 0001-Check-for-issetugid.patch
+0b2fef5a319978f6428e14866fd2bd2d 0002-remove-unused-execinfo.h.patch"
+sha256sums="a58ff4fabb01a25043b142185a33eeea961109dd60d4b40b6a9df4fa3cace20b libuser-0.62.tar.xz
+da99b8200a6e5b23fb288262300cefcfc4e16a1577cdb617aff8a4d4a19550c5 0001-Check-for-issetugid.patch
+facbdb7d01ce05f0eea539dba5379b1ca0976b226ef3962d567832966d01ce4f 0002-remove-unused-execinfo.h.patch"
+sha512sums="bc2f68456eae5912ac236192e97a3d66d5fa782520eff48d44d391c1ade590e001d821d7a93499e2391d0310cf03f60e4411f045f6ee3301af4e174d9ddc8450 libuser-0.62.tar.xz
+544f5124bf9a78daa99cf6d3f5b89c8519d7385aa7d1da9384fe29fea7285e61d7c91a865303258669232c3ed0590c8143e8acad66a6e1bc87069444e4af40b1 0001-Check-for-issetugid.patch
+b7da24da834b7e00e3449ab49c2187b0d8993079888b0900b62ec418db8fc025a22ee4b779715cc6ca327b614d97dd1fbf0a33f4f22fedade06782a3ba11f599 0002-remove-unused-execinfo.h.patch"