aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libxml++
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libxml++')
-rw-r--r--testing/libxml++/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/libxml++/APKBUILD b/testing/libxml++/APKBUILD
new file mode 100644
index 0000000000..a3a5858b77
--- /dev/null
+++ b/testing/libxml++/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=libxml++
+pkgver=3.0.1
+pkgrel=0
+pkgdesc="libbxml++ is a C++ wrapper for the libxml XML parser library."
+url="http://libxmlplusplus.sourceforge.net/"
+arch="all"
+license="GPL2"
+makedepends="libxml2-dev glibmm-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver:0:3}/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="9e95424a1c7231db91ce4058546de461 libxml++-3.0.1.tar.xz"
+sha256sums="19dc8d21751806c015179bc0b83f978e65c878724501bfc0b6c1bcead29971a6 libxml++-3.0.1.tar.xz"
+sha512sums="9b8ccea9df11d70bb23d7d9983b18d28c648aa0107f9654a79d1cfe97db4633b69dd4b97b76d155aca8553d014a314247851f18d0371717e44a056ee804ccd95 libxml++-3.0.1.tar.xz"