aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libyaml
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libyaml')
-rw-r--r--testing/libyaml/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/libyaml/APKBUILD b/testing/libyaml/APKBUILD
new file mode 100644
index 0000000000..4584087c86
--- /dev/null
+++ b/testing/libyaml/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=libyaml
+pkgver=0.1.4
+pkgrel=0
+pkgdesc="Yaml parser and emitter written in C"
+url="http://pyyaml.org/"
+arch="all"
+license=MIT""
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev"
+source="http://pyyaml.org/download/libyaml/yaml-$pkgver.tar.gz"
+_builddir="$srcdir"/yaml-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+ make check || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="36c852831d02cf90508c29852361d01b yaml-0.1.4.tar.gz"