aboutsummaryrefslogtreecommitdiffstats
path: root/testing/linphone
diff options
context:
space:
mode:
Diffstat (limited to 'testing/linphone')
-rw-r--r--testing/linphone/APKBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/testing/linphone/APKBUILD b/testing/linphone/APKBUILD
new file mode 100644
index 0000000000..a877f50f2d
--- /dev/null
+++ b/testing/linphone/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname="linphone"
+pkgver="3.12.0"
+pkgrel=0
+pkgdesc="An opensource SIP phone for voice/video calls and instant messaging"
+url="https://linphone.org/"
+arch="all"
+license="GPL-2.0"
+options="!check" # no test available
+makedepends="cmake ortp-dev readline-dev sqlite-dev
+ bctoolbox-dev libxml2-dev zlib-dev libnotify-dev
+ speex-dev mediastreamer2-dev belle-sip-dev belcard-dev belr-dev
+ libxv-dev v4l-utils-dev graphviz-dev doxygen sphinx
+ py3-pystache py3-six"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-sounds:sounds:noarch"
+source="https://www.linphone.org/releases/sources/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_MODULE_PATH=/usr/lib/cmake \
+ -DCMAKE_SKIP_INSTALL_RPATH=ON \
+ -DENABLE_SHARED=YES \
+ -DENABLE_STATIC=NO \
+ -DENABLE_CONSOLE_UI=YES \
+ -DENABLE_TOOLS=YES \
+ -DENABLE_DAEMON=YES \
+ -DENABLE_SQLITE_STORAGE=YES \
+ -DENABLE_STRICT=NO \
+ -DENABLE_VIDEO=YES \
+ -DENABLE_VCARD=YES \
+ -DENABLE_NLS=NO \
+ -DENABLE_LIME=NO \
+ -DENABLE_NOTIFY=YES \
+ -DENABLE_GTK_UI=NO \
+ -DENABLE_ASSISTANT=NO \
+ -DENABLE_STRICT=NO \
+ -DENABLE_ROOTCA_DOWNLOAD=NO .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/lib/cmake/Linphone
+ mv "$pkgdir"/usr/share/Linphone "$subpkgdir"/usr/lib/cmake/Linphone
+ mkdir -p "$subpkgdir"/usr/lib/cmake/LinphoneCxx
+ mv "$pkgdir"/usr/share/LinphoneCxx "$subpkgdir"/usr/lib/cmake/LinphoneCxx
+}
+
+sounds() {
+ pkgdesc="Sound files for $pkgname"
+ mkdir -p "$subpkgdir"/usr/share/sounds/linphone
+ mv "$pkgdir"/usr/share/sounds "$subpkgdir"/usr/share/sounds/linphone
+ # Remove empty dirs
+ rmdir "$pkgdir"/usr/share
+}
+
+sha512sums="d4b8c9976c19c468e7c9c9be519840d67861b0d79f8d0d84404ed70cde43434a6be38128f80341862b9f5ec57809bce79060db58550cd8661b31cefe4c6633f0 linphone-3.12.0.tar.gz"