aboutsummaryrefslogtreecommitdiffstats
path: root/testing/linux-vserver-sources/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/linux-vserver-sources/APKBUILD')
-rw-r--r--testing/linux-vserver-sources/APKBUILD39
1 files changed, 0 insertions, 39 deletions
diff --git a/testing/linux-vserver-sources/APKBUILD b/testing/linux-vserver-sources/APKBUILD
deleted file mode 100644
index 22097641d4..0000000000
--- a/testing/linux-vserver-sources/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-_suff=vserver
-pkgname=linux-$_suff-sources
-pkgver=2.6.29.2
-pkgdesc="Linux kernel sources with vserver patch"
-_kernver=2.6.29
-_vsver=2.3.0.36.10
-pkgrel=0
-options="!strip"
-license=GPL-2
-url="http://linux-vserver.org"
-source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
- ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
- http://vserver.13thfloor.at/Experimental/patch-$pkgver-vs$_vsver.diff
- 0001-linux-2.6.28.5-ipgre-strict-binding.patch
- 0002-linux-2.6.28.5-ipgre-optimize-hash-lookup.patch
- "
-
-build() {
- cd $srcdir/linux-$_kernver
- if [ "$_kernver" != "$pkgver" ]; then
- bunzip2 -c < ../patch-$pkgver.bz2 | patch -p1 || return 1
- fi
-
- for i in ../*.patch ../*.diff; do
- msg "Applying $i..."
- patch -p1 < $i || return 1
- done
-
- mkdir -p "$pkgdir/usr/src"
- cd "$srcdir"
- mv "linux-$_kernver" "$pkgdir/usr/src/linux-$pkgver-$_suff"
-}
-
-md5sums="64921b5ff5cdadbccfcd3820f03be7d8 linux-2.6.29.tar.bz2
-a3e79545ef18ff2a172f82fffef92deb patch-2.6.29.2.bz2
-df8fc25982478856480e8040c76d402c patch-2.6.29.2-vs2.3.0.36.10.diff
-7673b4521283ad41434a18ca18b16ad8 0001-linux-2.6.28.5-ipgre-strict-binding.patch
-8f405c738b150c532c46eaad5390cca2 0002-linux-2.6.28.5-ipgre-optimize-hash-lookup.patch"