aboutsummaryrefslogtreecommitdiffstats
path: root/testing/livestreamer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/livestreamer/APKBUILD')
-rw-r--r--testing/livestreamer/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/testing/livestreamer/APKBUILD b/testing/livestreamer/APKBUILD
index 4cd061415c..d75465fdb3 100644
--- a/testing/livestreamer/APKBUILD
+++ b/testing/livestreamer/APKBUILD
@@ -2,26 +2,25 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=livestreamer
pkgver=1.12.2
-pkgrel=4
+pkgrel=5
pkgdesc="Command-line utility that extracts streams from various services and pipes them into a video player of choice"
url="https://livestreamer.io/"
arch="noarch"
-license="BSD-2-Clause"
-depends="py-requests rtmpdump py-setuptools py2-singledispatch py-futures py-six py-crypto py-librtmp"
-makedepends="py-sphinx"
-source="$pkgname-$pkgver.tar.gz::https://github.com/chrippa/$pkgname/archive/v$pkgver.tar.gz"
-
+license="BSD-2-Clause AND MIT"
+depends="py3-requests rtmpdump py3-setuptools py3-crypto py3-librtmp"
+makedepends="py3-sphinx"
+source="$pkgname-$pkgver.tar.gz::https://github.com/chrippa/livestreamer/archive/v$pkgver.tar.gz"
build() {
- python2 setup.py build
+ python3 setup.py build
}
check() {
- python2 setup.py test
+ python3 setup.py test
}
package() {
- python2 setup.py install --root="$pkgdir" --optimize=1
+ python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="547886b494a7562e479cf31db15b5b02545f2ebc5f8b70d0fe0006d3748c5c9f20517638c7642377e2bdc4083738829eacf272e8d68f332da212bf65300f5d12 livestreamer-1.12.2.tar.gz"