aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lockrun/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lockrun/APKBUILD')
-rw-r--r--testing/lockrun/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/lockrun/APKBUILD b/testing/lockrun/APKBUILD
new file mode 100644
index 0000000000..4c45bc312f
--- /dev/null
+++ b/testing/lockrun/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Mikhail Snetkov <msnetkov@navikey.ru>
+# Maintainer: Mikhail Snetkov <msnetkov@navikey.ru>
+pkgname=lockrun
+pkgver=1.1.3
+pkgrel=0
+pkgdesc="Run cron job with overrun protection"
+url="http://unixwiz.net/tools/lockrun.html"
+arch="all"
+license="Public-Domain"
+options="!check" # No test suite.
+source="http://unixwiz.net/tools/lockrun.c"
+
+build() {
+ gcc $CFLAGS lockrun.c -o lockrun $LDFLAGS
+}
+
+package() {
+ install -Dm775 "$srcdir/lockrun" "$pkgdir/usr/bin/lockrun"
+}
+
+sha512sums="e31177ac47ff810c1900d4f97a8620d48f67b2cac3f2a7df45985934e2446e3afe35f4fc82b0e5dc7dcbc676521ba96bd535f172b3b0abb0bc0f5a152f750b3a lockrun.c"