aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lolcat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lolcat/APKBUILD')
-rw-r--r--testing/lolcat/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/lolcat/APKBUILD b/testing/lolcat/APKBUILD
new file mode 100644
index 0000000000..daa1fb5fe3
--- /dev/null
+++ b/testing/lolcat/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Daniel Isaksen <d@duniel.no>
+# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
+pkgname=lolcat
+pkgver=1.0
+pkgrel=0
+pkgdesc="High-performance implementation of lolcat"
+url="https://github.com/jaseg/lolcat/"
+arch="all"
+license="WTFPL"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jaseg/${pkgname}/archive/v$pkgver.tar.gz
+ fix-url-and-version.patch"
+options="!check" # No upstream testsuite
+
+build() {
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ make DESTDIR="$pkgdir/usr/bin" install
+}
+
+sha512sums="5f668706c2415273140047040a9e6d02d80a1572a834503480688f46466e2750f3cf5372f364039921f6461f2dbec7fa2dbe8a5600abdf3390c2caf56d1595bf lolcat-1.0.tar.gz
+14cdd61496bc0a0fbec39a8dcfb2d16d9424abfb1c6348750cb263fbb6a416bf89c6f05e549e1205fe64128c65946dcdde2a889c162336795e838b539c9b1470 fix-url-and-version.patch"