aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lua-xctrl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lua-xctrl/APKBUILD')
-rw-r--r--testing/lua-xctrl/APKBUILD39
1 files changed, 0 insertions, 39 deletions
diff --git a/testing/lua-xctrl/APKBUILD b/testing/lua-xctrl/APKBUILD
deleted file mode 100644
index 92871e548c..0000000000
--- a/testing/lua-xctrl/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=lua-xctrl
-pkgver=2010.10.26
-_x=${pkgver%%.*}
-_y=${pkgver%.*}
-_y=${_y#*.}
-_z=${pkgver##*.}
-_ver=${_x}-${_y}-${_z}
-pkgrel=0
-pkgdesc="Lua module that allows you to query and manipulate various aspects of an X11 window manager"
-url="http://jkp.t35.com/lua/"
-license="GPL-2"
-depends=
-makedepends="lua-dev libx11-dev libxmu-dev libiconv-dev"
-install=
-subpackages="$pkgname-doc"
-source="http://jkp.t35.com/files/xctrl-$_ver.tar.gz"
-
-_builddir="$srcdir"/xctrl-$_ver
-_lua_libdir=/usr/lib/lua/5.1
-prepare() {
- cd "$_builddir"
-}
-
-build() {
- cd "$_builddir"
- export EXTRA_CFLAGS="-fPIC"
- export EXTRA_LDFLAGS="-liconv"
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- install -d "$pkgdir"/$_lua_libdir "$pkgdir"/usr/share/doc/$pkgname
- install src/xctrl.so "$pkgdir"/$_lua_libdir/xctrl.so
- install doc/lxctrl.html "$pkgdir"/usr/share/doc/$pkgname/lxctrl.html
-}
-
-md5sums="edbe3385f1a660d1419d2d896c8cf106 xctrl-2010-10-26.tar.gz"