aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lua5.2-zmq/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lua5.2-zmq/APKBUILD')
-rw-r--r--testing/lua5.2-zmq/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/lua5.2-zmq/APKBUILD b/testing/lua5.2-zmq/APKBUILD
new file mode 100644
index 0000000000..33a4af3201
--- /dev/null
+++ b/testing/lua5.2-zmq/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua5.2-zmq
+pkgver=1.1_git20121231
+_ver=${pkgver%_git*}
+pkgrel=0
+pkgdesc="Lua zeromq2 binding"
+url="https://github.com/Neopallium/lua-zmq"
+arch="all"
+license="MIT"
+depends="lua5.2-llthreads"
+makedepends="zeromq-dev cmake lua5.2-dev"
+install=""
+subpackages=
+source="lua-zmq-$_ver.tar.gz::http://github.com/Neopallium/lua-zmq/archive/v$_ver.tar.gz
+ git-${pkgver##*_git}.patch"
+
+_builddir="$srcdir"/lua-zmq-$_ver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i -e 's:lua/5\.1:lua/5.2:g' CMakeLists.txt
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ . || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="cb4df81b4c884bf97bf6add88fcfa58d lua-zmq-1.1.tar.gz
+e568cb33eef6230454a70dddfd5d3978 git-20121231.patch"
+sha256sums="f2bdf3142b744971da4eb8bdb12020a34b62f8ba384be44d8448b4ef05ec3dcc lua-zmq-1.1.tar.gz
+9f3b2ddd87c0fd7064a317e5ed63c16c4d1999b020f3d98970f1c5962ed34354 git-20121231.patch"
+sha512sums="35d7da6215a96b80ea59b52591082473d2c54bcb9577ae95ead1235de894d5ef226b6c4e3030c327b2b146e07af6b3998d91c5b520dfb35e87c85e958069362d lua-zmq-1.1.tar.gz
+12ff90d9b01ca03f8c9f8e02e1392de839c19242570acb77d5078e4358a89dabe3df6f6b701a30b95121b35ed09a72eedd0259c34b2663e5193a963c588be64c git-20121231.patch"