aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lxc/APKBUILD')
-rw-r--r--testing/lxc/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/testing/lxc/APKBUILD b/testing/lxc/APKBUILD
index 95856e1d0c..042ae13c0a 100644
--- a/testing/lxc/APKBUILD
+++ b/testing/lxc/APKBUILD
@@ -3,7 +3,7 @@
pkgname=lxc
pkgver=0.7.4
_mypkgver=${pkgver/_rc/-rc}
-pkgrel=1
+pkgrel=2
pkgdesc="linux containers - tools"
url="http://lxc.sourceforge.net/"
arch="all"
@@ -13,7 +13,8 @@ depends_dev="libcap-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://lxc.sourceforge.net/download/lxc/$pkgname-$_mypkgver.tar.gz"
+source="http://lxc.sourceforge.net/download/lxc/$pkgname-$_mypkgver.tar.gz
+ lxc.initd"
_builddir="${srcdir}/${pkgname}-${_mypkgver}"
prepare() {
@@ -37,6 +38,8 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
+ install -Dm755 "$srcdir"/lxc.initd "$pkgdir"/etc/init.d/lxc
}
-md5sums="51bb5d7d9d22e2c98490aed47fc02ad9 lxc-0.7.4.tar.gz"
+md5sums="51bb5d7d9d22e2c98490aed47fc02ad9 lxc-0.7.4.tar.gz
+e66c3cf8e70168b07060746a4e65b671 lxc.initd"