aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxd/lxd-dont-go-get.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lxd/lxd-dont-go-get.patch')
-rw-r--r--testing/lxd/lxd-dont-go-get.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/testing/lxd/lxd-dont-go-get.patch b/testing/lxd/lxd-dont-go-get.patch
new file mode 100644
index 0000000000..506e56b956
--- /dev/null
+++ b/testing/lxd/lxd-dont-go-get.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile b/Makefile
+index 3a0cc01..1d54c9d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,13 +13,11 @@ TAGS=$(shell test -e /usr/include/sqlite3.h && echo "-tags libsqlite3")
+
+ .PHONY: default
+ default:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./...
+ @echo "LXD built successfully"
+
+ .PHONY: client
+ client:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./lxc
+ @echo "LXD client built successfully"
+