aboutsummaryrefslogtreecommitdiffstats
path: root/testing/madwimax
diff options
context:
space:
mode:
Diffstat (limited to 'testing/madwimax')
-rw-r--r--testing/madwimax/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/testing/madwimax/APKBUILD b/testing/madwimax/APKBUILD
index 251ff801ae..70367a6756 100644
--- a/testing/madwimax/APKBUILD
+++ b/testing/madwimax/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=madwimax
pkgver=0.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="WiMAX driver for the Samsung SWC-U200 and similar USB modems"
url="http://code.google.com/p/madwimax/"
license="GPL-2"
@@ -12,15 +12,19 @@ install=
subpackages="$pkgname-doc"
source="http://madwimax.googlecode.com/files/madwimax-0.1.1.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --without-man-pages \
+ || return 1
+ make || return 1
+}
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --without-man-pages \
- || return 1
- make || return 1
- make DESTDIR="$pkgdir" install
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
#2009-10-07,SP: you can start it simply by /usr/sbin/madwimax -d
#, so no init.d script so far...