aboutsummaryrefslogtreecommitdiffstats
path: root/testing/maildrop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/maildrop/APKBUILD')
-rw-r--r--testing/maildrop/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/maildrop/APKBUILD b/testing/maildrop/APKBUILD
new file mode 100644
index 0000000000..88e83757ab
--- /dev/null
+++ b/testing/maildrop/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Juraj Sujan <sujan@sofy.sk>
+# Maintainer: Juraj Sujan <sujan@sofy.sk>
+pkgname=maildrop
+pkgver=2.5.2
+pkgrel=0
+pkgdesc="Mail delivery agent with filtering abilities"
+url="http://courier-mta.org/maildrop/"
+arch="all"
+license="GPL3"
+depends=
+makedepends="perl pcre-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/courier/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2
+ http://www.max.rs/ozone/maildrop-2.3.0-dovecotauth.patch.txt"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+ if ! patch --verbose -p1 -i ../maildrop-2.3.0-dovecotauth.patch.txt; then
+ error "dovecotauth patch failed"
+ return 1
+ fi
+}
+
+build() {
+ cd "$_builddir"
+ # workaround for strange detection of default mailbox file/dir
+ export QMAIL="foo"
+ ./configure --prefix=/usr \
+ --disable-authlib \
+ --without-db \
+ --enable-syslog=1 \
+ --with-default-maildrop=./Maildir || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ mkdir "$pkgdir"/usr/share/doc
+ mv "$pkgdir"/usr/share/maildrop "$pkgdir"/usr/share/doc/
+ cp README.dovecotauth "$pkgdir"/usr/share/doc/maildrop/
+}
+md5sums="3edb56534ae442a494255db6c8aaab99 maildrop-2.5.2.tar.bz2
+f5e0fd910d76c4fba2a5fcdd40c6b375 maildrop-2.3.0-dovecotauth.patch.txt"