aboutsummaryrefslogtreecommitdiffstats
path: root/testing/marisa-trie
diff options
context:
space:
mode:
Diffstat (limited to 'testing/marisa-trie')
-rw-r--r--testing/marisa-trie/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/testing/marisa-trie/APKBUILD b/testing/marisa-trie/APKBUILD
index 3319201868..f966471e63 100644
--- a/testing/marisa-trie/APKBUILD
+++ b/testing/marisa-trie/APKBUILD
@@ -18,10 +18,20 @@ prepare() {
}
build() {
- ./configure \
- --prefix=/usr \
- --disable-static \
- --enable-sse2
+ case "$CARCH" in
+ x86|x86_64)
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ --enable-sse2
+ ;;
+ *)
+ ./configure \
+ --prefix=/usr \
+ --disable-static
+ ;;
+ esac
+
make
}