aboutsummaryrefslogtreecommitdiffstats
path: root/testing/masscan
diff options
context:
space:
mode:
Diffstat (limited to 'testing/masscan')
-rw-r--r--testing/masscan/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/testing/masscan/APKBUILD b/testing/masscan/APKBUILD
index 73615b2c6a..8a21caab7c 100644
--- a/testing/masscan/APKBUILD
+++ b/testing/masscan/APKBUILD
@@ -7,14 +7,13 @@ pkgdesc="Mass IP port scanner - This is the fastest Internet port scanner."
url="https://github.com/robertdavidgraham/masscan"
arch="all"
license="AGPL-3.0"
-depends="libpcap"
-makedepends="clang-dev libpcap-dev linux-headers"
+makedepends="libpcap-dev linux-headers"
source="$pkgname-$pkgver.tar.gz::https://github.com/robertdavidgraham/$pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- make
+ make CC="${CC:-gcc}" CFLAGS="${CFLAGS} -I."
}
check() {