aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mathomatic
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mathomatic')
-rw-r--r--testing/mathomatic/APKBUILD41
-rw-r--r--testing/mathomatic/busybox.patch11
2 files changed, 0 insertions, 52 deletions
diff --git a/testing/mathomatic/APKBUILD b/testing/mathomatic/APKBUILD
deleted file mode 100644
index 7a3ae6050a..0000000000
--- a/testing/mathomatic/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer:
-pkgname=mathomatic
-pkgver=16.0.5
-pkgrel=0
-pkgdesc="A software computer algebra system (CAS)"
-url="http://www.mathomatic.org/math/"
-arch="all"
-license="LGPL2+"
-depends="m4"
-depends_dev="readline-dev"
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-doc"
-source="http://mathomatic.orgserve.de/$pkgname-$pkgver.tar.bz2"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- make -f makefile READLINE=1 CC_OPTIMIZE="$CFLAGS" prefix="/usr" || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" prefix="/usr" m4install-degrees || return 1
-}
-
-
-md5sums="dd04913a98a5073b56f3bc78a01820f3 mathomatic-16.0.5.tar.bz2"
-sha256sums="976e6fed1014586bcd584e417c074fa86e4ca6a0fcc2950254da2efde99084ca mathomatic-16.0.5.tar.bz2"
-sha512sums="c44c60183442226562df9eefb1d77e5bafd96b7a5d3ad34a76963c586d398647366e782c75ffcf27c2b7d9d4be56678bbbc4d37ac71687a39f04b3fef450cc73 mathomatic-16.0.5.tar.bz2"
diff --git a/testing/mathomatic/busybox.patch b/testing/mathomatic/busybox.patch
deleted file mode 100644
index 07061ca60c..0000000000
--- a/testing/mathomatic/busybox.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- mathomatic-15.7.1.orig/makefile
-+++ mathomatic-15.7.1/makefile
-@@ -33,7 +33,7 @@
- CC ?= gcc # C compiler to use; this statement doesn't work usually, instead using cc.
- M4 ?= m4 # Change this to gm4 in Unix or a non-GNU system.
- INSTALL ?= install # Installer utility to use; change to ginstall under Unix.
--INSTALL_PROGRAM ?= $(INSTALL) -Cv # Command to install executable program files; compares to see if any differences, first.
-+INSTALL_PROGRAM ?= $(INSTALL) -c # Command to install executable program files; compares to see if any differences, first.
- INSTALL_DATA ?= $(INSTALL) -m 0644 # command to install data files
-
- CC_OPTIMIZE ?= -O3 # Default C compiler optimization flags that are safe.