aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mbuffer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mbuffer/APKBUILD')
-rw-r--r--testing/mbuffer/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/mbuffer/APKBUILD b/testing/mbuffer/APKBUILD
index 68634596d5..b0162d5bb6 100644
--- a/testing/mbuffer/APKBUILD
+++ b/testing/mbuffer/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Katie Holly <holly@fuslvz.ws>
pkgname=mbuffer
pkgver=20171011
-pkgrel=0
+pkgrel=1
pkgdesc="mbuffer buffers I/O operations and displays the throughput rate"
url="http://www.maier-komor.de/mbuffer.html"
arch="all"
-license="GPL-3.0"
+license="GPL-3.0-only"
depends=""
makedepends="linux-headers libressl-dev"
install=""
@@ -26,9 +26,14 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check TESTTREE=./
+}
+
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
+ make -j1 DESTDIR="$pkgdir" install
}
sha512sums="398d7545388a94b4f8961193192cd5e1139b84f31c7699c2b7f66b84a40488a2e70c88a2a70578bd95375e11efc87978a5f6fec805dbbc5f1fea460b3a9c68c4 mbuffer-20171011.tgz"