aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mono/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mono/APKBUILD')
-rw-r--r--testing/mono/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/testing/mono/APKBUILD b/testing/mono/APKBUILD
index 70587f111c..41fbcc95cf 100644
--- a/testing/mono/APKBUILD
+++ b/testing/mono/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=mono
-pkgver=4.0.1
-pkgrel=1
+pkgver=4.0.4.1
+pkgrel=0
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
url="http://www.mono-project.com/"
arch="all"
@@ -12,9 +12,11 @@ depends_dev="zlib-dev libgdiplus-dev"
makedepends="$depends_dev python linux-headers paxmark autoconf automake libtool"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://download.mono-project.com/sources/mono/mono-${pkgver/_/~}.tar.bz2"
+source="http://download.mono-project.com/sources/mono/mono-${pkgver/_/~}.tar.bz2
+ assume-UTC-if-no-TZ-set.patch
+ "
-_builddir="$srcdir"/mono-${pkgver%%_*}
+_builddir="$srcdir"/mono-${pkgver%.*}
prepare() {
local i
@@ -52,11 +54,15 @@ build() {
package() {
cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install || return 1
# mark all bins
- paxmark -mr "$pkgdir"/usr/bin/*
+ scanelf --nobanner "$pkgdir"/usr/bin/* | awk '{print $2}' \
+ | xargs paxmark -mr
}
-md5sums="426065ce1aba25fd3e776ea736c5f430 mono-4.0.1.tar.bz2"
-sha256sums="ff1f15f3b8d43c6a2818c00fabe377b2d8408ad14acd9d507658b4cae00f5bce mono-4.0.1.tar.bz2"
-sha512sums="b021ef977a1044718ea16b5f2ed50c2a75a469b1f359ae397acb830ad2e9406bb83129856d4975c39146ec464fe4e0a665b9e80a473ccfeb835eb9198717763b mono-4.0.1.tar.bz2"
+md5sums="f598b60a664dfebb1a5eef3e66a9a178 mono-4.0.4.1.tar.bz2
+4a762b5e095baf78705d39fc2918fca7 assume-UTC-if-no-TZ-set.patch"
+sha256sums="ed11ed20ce5930c775af02bd41c43658bc9320f0bfd592fbb9895d95104dbcf9 mono-4.0.4.1.tar.bz2
+1be0b3ecf2949d79298f5b449b710a78610933f165fe2c10c37b84cf26383f56 assume-UTC-if-no-TZ-set.patch"
+sha512sums="2f299e97dd3014c9d221677e73e5134a0c0a5b27e479fb60aabc2b3eddedf07f525f3a74194ccbfdf8efe63d7ea72850f8ee64d6f15f51bccd5db0df6c1b3722 mono-4.0.4.1.tar.bz2
+aa294f81fb7f5815ef37ad191e41766836e95bf3e0ce2592e6da88cbb6c2e408b2e4cbd9c81d39f3e575ba3f1590dba5abe26d8b465b56d3f25e228dbb0ddf70 assume-UTC-if-no-TZ-set.patch"