aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mono
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mono')
-rw-r--r--testing/mono/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/mono/APKBUILD b/testing/mono/APKBUILD
index d9d7951dc6..cfb901d0e9 100644
--- a/testing/mono/APKBUILD
+++ b/testing/mono/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="GPL"
depends=""
depends_dev="zlib-dev libgdiplus-dev"
-makedepends="$depends_dev python linux-headers autoconf automake libtool"
+makedepends="$depends_dev python linux-headers autoconf automake libtool paxctl"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://download.mono-project.com/sources/mono/mono-$pkgver.tar.bz2
@@ -24,6 +24,9 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ sed '/exec "/ i\paxctl -mr "$r/@mono_runtime@"' \
+ -i runtime/mono-wrapper.in \
+ || return 1
}
build() {