aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mosh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mosh/APKBUILD')
-rw-r--r--testing/mosh/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/testing/mosh/APKBUILD b/testing/mosh/APKBUILD
index 6d18b42a72..fe56728edb 100644
--- a/testing/mosh/APKBUILD
+++ b/testing/mosh/APKBUILD
@@ -3,17 +3,16 @@
pkgname=mosh
pkgver=1.2.4
pkgrel=0
-pkgdesc="mobile shell (mosh) surviving disconnects with local echo and line editing"
+pkgdesc="Mobile shell (mosh) surviving disconnects with local echo and line editing"
url="http://mosh.mit.edu"
arch="all"
-license="GPL3"
+license="GPL3+"
depends="perl-io-tty"
makedepends="ncurses-dev zlib-dev openssl-dev perl-dev perl-io-tty protobuf-dev"
subpackages="$pkgname-doc"
source="http://$pkgname.mit.edu/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
-
build() {
cd "$_builddir"
./configure --prefix=/usr \
@@ -23,7 +22,7 @@ build() {
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install || return 1
}
md5sums="c2d918f4d91fdc32546e2e089f9281b2 mosh-1.2.4.tar.gz"