aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nodejs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/nodejs/APKBUILD')
-rw-r--r--testing/nodejs/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/nodejs/APKBUILD b/testing/nodejs/APKBUILD
new file mode 100644
index 0000000000..e0d76551e9
--- /dev/null
+++ b/testing/nodejs/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=nodejs
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="event-oriented javascript framework and execution environment"
+url="http://nodejs.org/"
+
+# v8 is not portable so we have to list archs by hand
+arch="x86 x86_64 arm"
+
+license="MIT BSD Apache-2"
+depends=
+depends_dev=
+makedepends="$depends_dev python libev-dev c-ares-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://nodejs.org/dist/node-v${pkgver}.tar.gz
+ nodejs-uclibc.patch
+ nodejs-multiplicity.patch"
+
+_builddir="${srcdir}/node-v${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --shared-cares \
+ --shared-libev
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="9e9e791e125f6a601ebc663dc99c72a8 node-v0.4.2.tar.gz
+b5d7568f58bb9a14d5b9a971e89560c6 nodejs-uclibc.patch
+912d504d56fb194b4ceda8f693f6e200 nodejs-multiplicity.patch"