aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nomad/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/nomad/APKBUILD')
-rw-r--r--testing/nomad/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/nomad/APKBUILD b/testing/nomad/APKBUILD
new file mode 100644
index 0000000000..932ecbb31f
--- /dev/null
+++ b/testing/nomad/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Matthias Neugebauer <mtneug@mailbox.org>
+# Maintainer: Matthias Neugebauer <mtneug@mailbox.org>
+pkgname=nomad
+pkgver=0.9.5
+pkgrel=0
+pkgdesc="An easy-to-use, flexible, and performant workload orchestrator"
+url="https://www.nomadproject.io/"
+arch="all"
+license="MPL-2.0"
+depends="cni-plugins"
+makedepends="linux-headers bash make go python2 yarn npm go-bindata-assetfs"
+subpackages="$pkgname-openrc"
+options="!check" # cannot produce environment for testing in CI
+source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/$pkgname/archive/v$pkgver.tar.gz
+ nomad.initd
+ nomad.confd
+ nvidia-driver.patch
+ server.hcl
+ static-assets.patch"
+builddir="$srcdir/src/github.com/hashicorp/$pkgname"
+
+prepare() {
+ mkdir -p "$srcdir/src/github.com/hashicorp"
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+ default_prepare
+}
+
+build() {
+ make ember-dist
+ GOPATH="$srcdir" CGO_ENABLED=1 GO_TAGS="ui release" make static-assets
+ GOPATH="$srcdir" CGO_ENABLED=1 go build -v -o bin/$pkgname \
+ -ldflags "-X github.com/hashicorp/nomad/version.GitCommit='$pkgver'" \
+ -tags "ui release"
+}
+
+check() {
+ GOPATH="$srcdir" CGO_ENABLED=1 go test -timeout=15m "./..."
+}
+
+package() {
+ install -m755 -D "$srcdir/$pkgname.initd" "$pkgdir/etc/init.d/$pkgname"
+ install -m644 -D "$srcdir/$pkgname.confd" "$pkgdir/etc/conf.d/$pkgname"
+
+ install -m750 -o root -g root -D bin/$pkgname "$pkgdir/usr/sbin/$pkgname"
+ install -m640 -o root -g root -D "$srcdir/server.hcl" "$pkgdir/etc/nomad.d/server.hcl"
+ install -m750 -o root -g root -d "$pkgdir/var/lib/$pkgname"
+}
+
+sha512sums="97d3539c0446a7b89ebc6fea4270a93ed3588e0632162e653b11a38fff1754eb25e0f9ee9618f639fd633d66f1eb72c66e7b114713c5f4922462c0524f51508a nomad-0.9.5.tar.gz
+ac969c81150ba57871c1f75f17c11d06ffc7bcc872882416c7c0d9d43f5e352ca1b7e7bfd75e32a9d01a826496c77a657dc298f5e048f85b4d9e85bc3afee51d nomad.initd
+a4fcc9f319926e8e5257dcc902cf3e1cbacd8bee82097b7a9719611d52037431a7e953a4b0fa90fc25475d2590cd14877c8e4c87bd909dd0099a754ba6f5063c nomad.confd
+e9c0161c2a9c0e1933c266520a410764a709c7b4f65b1a81c1fb2494eae89daa847ffca5df46d6eea61d855f35d21e66433ec0afe8c08017187c917e952b8544 nvidia-driver.patch
+c2ba7db5bb0858547bf346819945d24626ac761541f38350b40408e1b26227549f6aa4d6946baadbf856329c0ac9f81f84164597d11361224b62a1697f17e726 server.hcl
+3810c6e0d3e5c202567ac95d04e363b4f28bf39e37a746c5c50b38c18bec3b6256d25f9e0a7fcbe7b7b12dbb007cdefe029a8b74fe8190d019c717d77a9a77fd static-assets.patch"