aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nx-libs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/nx-libs/APKBUILD')
-rw-r--r--testing/nx-libs/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/nx-libs/APKBUILD b/testing/nx-libs/APKBUILD
new file mode 100644
index 0000000000..68df0da9c2
--- /dev/null
+++ b/testing/nx-libs/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Jean-Charles de Longueville <jch@hellea.eu>
+# Maintainer:
+pkgname=nx-libs
+pkgver=3.5.0.31
+pkgrel=0
+pkgdesc="NoMachine libraries (redistributed by x2go)"
+url="http://x2go.org"
+arch="all"
+license="GPLv2+"
+depends="font-cursor-misc font-misc-misc"
+depends_dev=""
+makedepends="$depends_dev libx11-dev zlib-dev libjpeg-turbo-dev libpng-dev libfontenc-dev linux-headers libxml2-dev bash automake autoconf"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://code.x2go.org/releases/source/$pkgname/$pkgname-$pkgver-full.tar.gz
+ xf86bigfont.patch
+ fix-musl-headers-x86.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ #Every Makefile has /usr/local as PREFIX, so replace that
+ sed -i -e 's,/usr/local,/usr,' nx-X11/config/cf/site.def
+}
+
+build() {
+ cd "$_builddir"
+ make -j1 PREFIX=/usr USRLIBDIR=/usr/lib SHLIBDIR=/usr/lib CONFIGURE="./configure --prefix=/usr --libdir=/usr/lib --includedir=/usr/include" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ #find ./ -name Makefile | xargs sed -e 's#/usr/local#/usr#g' -i
+ make PREFIX=/usr DESTDIR="$pkgdir" USRLIBDIR=/usr/lib SHLIBDIR=/usr/lib install CONFIGURE="./configure --prefix=/usr --libdir=/usr/lib --includedir=/usr/include" || return 1
+}
+
+md5sums="d163193f2c344aad263da0fc4fe4b853 nx-libs-3.5.0.31-full.tar.gz
+6030f6b55bcd54be7a5f9c5e796d3759 xf86bigfont.patch
+5f26a25ccc1d50693c0b4efe287a95f2 fix-musl-headers-x86.patch"
+sha256sums="2130db3bf5c0b081604aef5546fd2c2a5f4db26ce2297a8da3cb3bcf11286128 nx-libs-3.5.0.31-full.tar.gz
+51dc9bad9cc410654bf6c657abdd1bfb2ec5e6e6349ffb701b39cc11e46d2c2e xf86bigfont.patch
+a09d175c62e1ae6017e161ccb7ed56b38da26ad2fa95b74357c9e4e78034b56f fix-musl-headers-x86.patch"
+sha512sums="88870ec0453ab8e1fe3274ed86ac577256b14ea2ec448491f975be6d673ef8e60fb342601f05da819e202adc2bf668327e1f6c49b1ba79eb52faa87ed9e8985e nx-libs-3.5.0.31-full.tar.gz
+ee090f4e7f5933cbea6398ac461539cbdc8b7fd62f32934c78298c1e217d2a60e7f796bffdb88d36816bbfa9becd810846f5b988b5191e5a5b9da5def5d730fa xf86bigfont.patch
+d4a881b66f0258d6d9fb947a526868944e58217d534316dfa3f0837035415467a1e8841bf6c5b821ccedcc0c9e07b425f05243ddbd22aaec7ea2165c87d9211e fix-musl-headers-x86.patch"